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Alibre Design Tutorial: Sweep, Extrude (Boss & Cut), & Fillet
Sweep_Foot-Scrubber-1

Part Tutorial

Exercise 8: Sweep_ Foot-Scrubber-1 [Complete Version]

In this Exercise, We will set System Parameters first, then part options,
Then setting up the save, at the beginning - so as to save easily as we perform each step.
Then, in sketch mode, we will set the first sketch of the scrubber for the Sweep Feature.
Then we will use the Sweep Feature to create the Primary Smooth edge.
Next, We will use a Feature Mirror to replicate the Sweep to cover Both Sides,
Then we will create a sketch and use Extrude Boss it to fill in the middle of the handle.
Then we will create a sketch and use Extrude Cut to make the hole in the handle.
We will fillet the edges of this hole for a smooth finish,
Setting the Color Properties will follow this, and re-saving the file.

Launch Alibre Design.
From the Home window - select File, Work Offline. (You may switch to work online later)
(Also - Even though these pictures show 'Alibre Design Expert' - these are basic instructions that can be
done without Professional or Expert Versions.)

Open a New Part workspace. From the Home window - click on the New Part icon.
Maximise the Part Workspace Window.

*If at any time you are not sure of a keyboard item, see: Keyboard Basics or Here.

http://www.aarp.org/Articles/a2002-07-15-keyboardbasics/tools/printable
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Set Design Properties.
Select File, Properties. (Keyboard shortcut = Alt+Enter)

A)   Select the Tab Marked "General"
• In Description: insert the information: 'Sweep_Foot-Scrubber-1'.
• In Curve Smoothness, Select the Radio Button marked 'Manual', and

set the 'Minimal Circular Facets:' at 72.

B) Select the Tab Marked "Units"
• Check (check mark in box is showing ) the Box Show Units for Dimensions.
• On Display Units - confirm Unit: Inches, Format: Decimals, and Precision: 4.

• On Angle - Confirm Angle: Degrees and Precision: 3. Adjust if not.
• On Spinner Increment - for Length: enter 0.1000 " and for Angle: enter 1.000 o (degrees).

 Adjust to these parameters if not. Press 'Tab' to move after editing them.
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C)   Select the Tab Marked "Apply Options"
• On Apply Changes to - Click the Radio Button beside The Current Document.
• Click Apply, then Click Close.

Set Part Options.
From Top Text Menu - Select - Tools > Options > (Crtl-Shift-O)
General Tab > Selected or checked off (check off = check mark in box) are:
Global - Show popup on errors,
Hints - All

Design
- Prompt for newer versions, - Snap to working plane, - Prompt to edit sketch,
- Prompt on detecting parameters with missing external link, - Reorient on extrude,
- Keep model in View, - Prompt when not sketching on face.
Show as Default - Planes, Annotations, and Sketches. Number of stored previous/next views: 64
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Grid Tab> Spacing: Make X: .125 " and Y: .125 ", check off Display grid, and Snap to grid.
Color Scheme Tab> For Scheme: - confirm - Dark Background Scheme. Click 'OK'.
(You may come back to this at any time later - and edit - or change - any element.)

Now you have set up the workspace to easily create the Model, next you will set up the save. (This
is the recommended procedure to safely keep your file up to date, while you are working on your file.)

Set-up Save.
Now, to save this in it's own folder, making it easy to simply save as we proceed:
• From the main text menu, select File, Save As. (Also Press Ctrl+Shift+S, the Shortcut Keys)
• From the Save As popup, under the File System Explorer directory view - select Tutorials folder.

• Click on New Folder - create one with the name Sweep_Foot-Scrubber under Tutorials.
• Select this new folder named: Sweep_Foot-Scrubber
• Edit the name of the part - to: Sweep_Foot-Scrubber-1, and click - Save.

Ok - All set-up and ready to go!
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Start the First Sketch for the Sweep Path (This is a bit long!).
In the Design Explorer, confirm The X-Y Plane is selected under Planes.
From the Sketch Icons > Click Activate Sketch. (The first Icon) (The XY-Plane should be selected.)
Or, you can select Activate Sketch from the Sketch Menu, or press Ctrl+K.

From the Sketch Icons > Click Line Options (Below Line Icon) -> Select Reference Line

(Note:  the Cursor Icon for the Reference Line - is broken/dotted.)

• Click the Origin, and drag a vertical Reference Line up the 'Y' Axis 6.250 " - Double Click,
• Click the Origin, and drag a vertical Reference Line down the 'Y' Axis 3.125 " - Double Click,
• Still using the Reference Line, create 8 horizontal lines to the right of the two vertical lines,
• We will add dimensions and force the lines into place after placing them:
• Place a short line .375 " Long from the axis and from the top end of the top line,
• The 2nd short line .70 " Long, .45 "

(about 4 grid squares) below the first line,
• The 3rd short line .40" Long, 1.60"

(about 12 grid squares) below the second line,
• The 4th short line .60 " Long, 0.90 "

(about 6-7 grid squares) below the third line,
• The 5th short line .375" Long, 1.175"

(about 9 grid squares) below the fourth line,
• The 6th short line 1.1250" Long, 2.750"

(22 grid squares) below the fifth line,
• The 7th short line .625" Long, 2.25"

(18 grid squares) below the 6th line
(2 square up from the bottom end of the bottom line)

• The 8th short line .25" Long running from the
bottom end of the bottom line out to the right.

Click Zoom to Fit - so everything is on screen.
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From the Sketch Icons > Click Dimension (4th Icon down, note the cursor icon)

• Click the Bottom Reference Line, and drag the dimension below it - Click,
Confirm the Length is .2500 " or edit to be .2500 " and press Enter.

• Click the next reference line up from the bottom, and drag the dimension above it - Click and
confirm the Length is.6250 " or edit it to that, and press Enter.

• Click the third reference line up from the bottom, drag the dimension above it, Click and confirm the
Length is 1.1250 " or edit it to that, and press Enter.

• Click the fourth reference line up from the bottom, drag the dimension down below it, click and
confirm the Length is.3750 " or edit it to be that, and press Enter.

• Click the fifth reference line up from the bottom, drag the dimension below it, Click and confirm the
Length is.6000 " or edit it to be that, and press Enter.



Page 7 of 27

• Click the sixth reference line up from the bottom, drag the dimension above it, click and confirm the
Length is .4000 " or edit it to be that, and press Enter.

• Click the seventh reference line up from the bottom, drag the dimension below it, Click and confirm
the Length is .7000 " or edit it to be that, and press Enter.

• Click the eighth reference line up from the bottom, drag the dimension up above it, Click and
confirm the Length is .3750 " or edit it to be that, and press enter.

Now - Measure and confirm the length of the two Vertical Reference Lines.
• First, Click the upper Reference Line and drag out to the left to place the Dimension, Click, and

confirm or edit the Value to be 6.25 ", Click Enter.
• Second, Click the Lower Reference Line and drag out to the left to place the Dimension, and

confirm or edit the value to be 3.125", Click Enter.
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Now would be a good time to save the work done.

Simply Click the Save Icon (Disk). Click Save in the Dialog Box
Saving exits the sketch mode, and creates Sketch<1> under Features in the Design Explorer.
To return to the Same Sketch, Right-Click on the Sketch<1> Listing, and select Edit.

This has completed setting the lines and specifying their lengths.

Now we will use Ordinate Dimensions to identify the lines with reverence to a base line and
then edit these dimensions to lock the heights of the short lines where we want them.

First - Select Zoom to Fit           from the View Toolbar, to get the whole sketch into view, and make
sure the workspace window is still maximised.
• Right Click in the Part Workspace area, and select Ordinate Dimension from the popup menu,
• Next step is to pick a baseline to determine the direction of the running dimensions:

(Note the Status Bar Hints) - Click the small horizontal reference line at the top, (0.375 " Length)
• Then - to pick an origin point or figure: we will pick the end point of the first short reference line at

the top to set out ordinate 0" point,
• Then - we will click to one side - to locate the side the dimensions will be placed.

• Next - pick the next line down - end point, to measure it in reference to the 0.00 point, drag the same
side again, click and the dimension is placed.

• Continue down clicking end points and dragging the lines to one side until finishing at the 8th line.



Page 9 of 27

When done placing the dimensions - Click on Select in the Sketch Icons -  to exit
Ordinate Dimension.

Now - we will edit these Dimensions to set the lines at the right heights:
• Double Click the first Ordinate dimension below .0000 " (~.5000") and edit it to .4500 ", Click Enter

• Double click the next down Ordinate Dimension (~ 2.125 ") and edit it to be 2.0500 ", Click Enter,

• Double click the next down Ordinate Dimension (~ 3.00 ") and edit it to be 2.9500 ", Click Enter,

• Double click the next down Ordinate Dimension (4.125") and confirm it to be 4.1250 ", Click Enter,

• Double click the next down Ordinate Dimension (6.875") and confirm it to be 6.8750 ", Click Enter,

• Double click the next down Ordinate Dimension (9.1250") and confirm it to be 9.1250", Click Enter,
Then Click & Drag it up slightly to a clear spot.

•  The last Ordinate Dimension should be in Brackets and should read (9.3750 ") - meaning it is fixed
and can not be edited. Click on it and drag the Dimension down to a clear space. Note the offset line.

Now we have all the lines with end points located as required we can connect the B-Spline to them.

This would be another good time to save the work done.
Simply Click the Save Icon (Disk). Click Save in the Dialog Box
Saving exits the sketch mode, and creates Sketch<1> under Features in the Design Explorer.

To return to the Same Sketch, Right-Click on the Sketch<1> Listing, and select Edit.

Click Zoom to Fit - so everything is on screen.
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Now to add the B-Spline
From the Sketch Icons > Click B-Spline by Control Points (9th Icon down, note the cursor icon)
If B-Spline by Control Points is not currently selected, you may click the option button, and select the
icon from the Flyout menu.

• Use Zoom to Fit, and Zoom to Window as required to see the line end points clearly.

• First, Click the Top end of the Top Vertical Reference Line,
• Then moving to the right, click the end of the line at .3750 ", .0000 " (The first short line)
• Then, moving down and to the Right, Click the end of the line at .7000 ", .4500 " (2nd Line)
• Moving Further down, Click the end of the line at .4000 ", 2.0500 " (3rd Line)
• Continuing down, Click the end of the line at .6000 ", 2.9500 " (4th Line)
• Next, Click the End of the line at .3750 ", 4.1250 " (5th Line down)
• Next, Click the end of the line at 1.1250 ", 6.8750 " ( 6th Line down)
• Then Click the end of the line at .6250 ", 9.1250 " (7th Line down)
• Now Click the end of the line at .2500 ", (9.3750 ") (8th Line down)
• Finally, Double Click the bottom end of the two vertical lines to complete the B-Spline.
• Now Click Select in the Top Icons to exit sketch and create Sketch<1>

For a look at the whole sketch, click here.
This completes the Sketch for the Sweep Path Object.

http://aircraft-computational.com/alibre/assistance/Initial-Foot-Scrubber_Handle-Sketches_1a.pdf


Page 11 of 27

Now we will create the Sketch to Sweep Object.

If Still in Sketch Mode, Select Activate Sketch
(While we are in the Sketch Mode - this is a toggle - to Exit Sketch Mode)

In the Design Explorer, Click YZ-Plane, then from the Sketch Icons, Click Select
- to activate sketch and sketch on this plane.

From the Sketch Icons > Click Line Options (Below Line Icon) -> Select Reference Line

(Note:  the Cursor Icon for the Reference Line - is broken/dotted.)

• Click the Origin, and drag a vertical Reference Line down 3.1250 " along the Y-Axis, Double Click.

From the Sketch Icons > Click Line Options (Below Line Icon) -> Select Line from the Flyout
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• Click the bottom end of the reference line; drag out a line .3750 " up the Y-axis, Double Click.

From the Sketch Icons > Click Offset (3rd Icon from the Bottom)

• Click in the white area under Figures to Offset, in the Offset dialog, the selection becomes Bold.
• Click the line just created to Select it, - Line<1> is displayed in the figures to offset,
• Click - Drag in the distance selection to highlight the value, the selection becomes Bold,
• Set the Distance to be 1/16 " (enter 1, enter '/' enter 16, press tab, value changes to become .0625),
• Click OK,

• Click the Offset Icon again, Line<1> is still selected, and distance is still .0625.
• This time Click - Flip direction, then click OK.

Use Zoom to Window to drag a selection around the two new lines, to get a close up view.
• Delete the center Line - if it is still selected (Yellow) or re-select it first, press the Delete Key.
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From the Sketch Icons > Click Line (The 5th Icon down) Connect these two lines.
• Click the upper end of the left line and the upper end of the right line, Double Click.

From the Sketch Icons > Click Circle (The 6th Icon down)
• Click the lower end of the reference line between the connected lines,
• Drag out a circle to the first grid intersection to the right, Click.

From the Sketch Icons > Click Dimension (4th Icon down)

• Click the center of the circle, and then the edge, you will notice Tangent Constraints are inserted,
drag out the cursor to locate the dimension and Click.

From the Sketch Icons > Click Select (2nd Icon down)
• Mouse over the Tangent constraints, click and press Delete to remove them.

Again from the Sketch Icons > Click Dimension (4th Icon down)
• Edit the dimension to 3/32 and press Enter. The Displayed Dimension will be R.0938.
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• Click the short line connecting the two parallel lines, drag the dimension location up and to one side,
Click, Press Enter to accept the dimension (.1250 ")

From the Sketch Icons > Click Select (2nd Icon down)
• Click the Reference Line to select it, and press Delete.

From the Sketch Icons > Click Trim Figure (6th Icon up from Bottom)
• Click on the excess tails of the parallel lines inside the Circle to trim them,
• Click the inside segment of the circle between the two parallel lines, to trim it.

From the Sketch Icons, Select Activate Sketch
(We are in the Sketch Mode - this is a toggle - to Exit Sketch Mode. It becomes unselected)
We now see Both Sketch<1> and Sketch<2> under Features in the Design Explorer.

This would be another good time to save the work done.
Simply Click the Save Icon (Disk). Click Save in the Dialog Box

Next you will create the Models' first Solid Feature - a Sweep

From the Feature Menu Select Boss -> Sweep, or
From the Feature Icons Select Sweep Boss. (7th Icon down)
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• In the Sweep Boss dialog, Click inside the white area below Sketch to Sweep to select it if it is not
already bold,

• Click Sketch<2> in the Design Explorer,
• Click in the white Space under Path Object, Click Sketch<1> in the Design Explorer,
• Leave Sweep Type set for Entire Path, Draft Angle at 0, and Label as Sweep<1>,
• Go ahead and Click OK to Complete the Sweep.

To see a better view of it, Click the View Orientations Icon, from the View Toolbar, and select
Isometric from the list in the Orientations popup, Click Set, and then Close it.
You can also Click Orient to Isometric from the Orient View Toolbar.
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Now, We will create the other half of the sweep by using a
Feature Mirror to close the shape.

From the Feature Menu, Select Mirror
• In the Feature Mirror dialog, click in the white space under Features to mirror:
• In the Design Explorer, Click feature Sweep<1> - it will be displayed in the Feature to mirror

segment,
• Then click in the white space beside Mirror plane:
• Click the YZ-Plane, either in the Design Explorer, or in the Part Workspace,
• Quickly you will see the light blue wireframe preview of where the Mirror Feature will be,
• Make sure Mirror Geometry is checked, and Click OK to complete the Mirror operation.
• This will Create Mirror<2> (The Second Feature item in this Project, default numbering)

This Completes the Mirror Feature.
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Next, we will use Extrude Boss to fill the middle portion left by creating the sweep first.

Start by using Zoom to Fit, or Rotate the view to a suitable angle and plane to allow an easy click
to one of the flat inside surfaces on the original Sweep.

• Also, you can click left and right mouse buttons while the cursor is in the Part Workspace to rotate
the view,

• Click the surface, then Select from the Insert menu, -> Plane,

• In the Insert Plane dialog, The Select Geometry: is pre-selected with Face<3>,
• Under Plane Offset Distance, Leave the Distance at .0000 ", and Click OK.
• Plane<3> is created and displayed in the Design Explorer, below Mirror<2>.
• Click in the open part workspace are to de-select planes and references.

Use this new Plane as the Sketch Plane now by selecting it in the Design Explorer, and clicking
Activate Sketch in the Sketch Icons.
• When the Sketch is now active - you will see the grid over the Sweep and Mirror Features,

•  Shift-Click the inside of the Sweep and the Mirror Feature Edges, (Note the Cursor Icon for Edge
Selection). Then Click Project to Sketch Icon,
(Bottom of the Sketch Icons, it may also be selected from the Sketch Menu.)
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• Edge<8> and Edge<10> become displayed in the Project to Sketch selection popup
under Entities to project,

• Default is Create sketch figure - change that to the selection beside Create reference figure,
• Click OK.

Now what we will do - is offset the edges into the sweep and mirror areas using Offset.

Press Ctrl+A (Control key and the 'A' key at the same time) to Select All the sketch items
From the Sketch Icons, Click - Offset (3rd icon from the bottom)

• From the Offset selection dialog, you should see in Figures to offset - two items already selected:
Reference B-Spline<1>, and Reference B-Spline<2>

• Edit the Distance to be .1000 " and make sure the blue line is over the existing Sweep and Mirror,
• If not - Click the selection beside Flip Direction. Leave Gap Type at Natural, and Click OK.

Now you can check for any issues with the lines, using the analyse feature.
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From the Sketch Menu > Select Analyse
• The Analyse Sketch popup has a number of selections to check - marked with boxes beside them -

for this exercise - they all should be checked,
• Click the Analyse Button - Ideally you should see a message below this button that is now displayed

stating "No Potential problems detected in the sketch for the current check levels…"
• If not - (IE: Disjoint Ends), Click the error, and it will be displayed in the sketch, and if it can be

Healed automatically, the Heal button will no longer be Greyed out. Click it to fix the error.
(That is why you want them all checked in the boxes!) (Email me if you get stuck on this one)

• Click Close.

Now you can make the Extrusion to fill the center area of the handle.

While in the Sketch mode - Click Boss, Extrude, under the Feature menu, or
Click Extrude Boss from the Features Icons

• Unless used recently in this project with another setting or distance, the Extrude Boss selection
popup will usually open with a default distance of 5" (5.0000 " with the current properties setting)

• Pre-selected - under Sketch will be Sketch<3>, the sketch we just made,
• Set the Type: To Geometry, Leave Direction  set to Along Normal, and Draft Angle set to 0,

mailto:alibre_rob@hotmail.com?subject=Analyse Issue  Sweep_Foot-Scrubber-1
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• Click left and right mouse buttons while the cursor is in the Part Workspace to rotate the view of the
sweep/mirror item until you see the opposite side, or back face from where we began,

• Click in the To Geometry Target: selection area, then Click this back face for the 'To Geometry'
setting,

• Face<5> is now displayed in this selection. Leave Offset at .0000 ", and Label: as Extrusion<4>,
• Click OK -when all things are set up and confirmed to complete the extrusion fill of the Middle.

One thing left to Model, the shaped hole in the handle.

While we might be able to edit the last extrusion and simple modify the sketch there, for this
exercise - we will create a new sketch on the new surface, and use Extrude Cut to create the hole.

First - Click Orient to Front from the Orient View toolbar, or

Click View Orientation from the View toolbar, and

Select: Front(XY), Set, Close.
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Click in the all Flat area between the Circular Edges of the Foot Scrubber Model to Select it, then
click Select from the Sketching toolbar (Sketch Icons).
• Now in Sketch mode - use the Zoom to Window to zoom in on the slim handle area (Top) of the

view,

From the Sketching toolbar > Click Line Options (Below Line Icon) -> Select Reference Line
(Note:  the Cursor Icon for the Reference Line - is broken/dotted.)

• Click the Y-Axis to set the start of the reference line - just above the edge of the Sweep, and place a
horizontal line along the grid, about 0.25" Long. Double Click.

From the Sketching toolbar, Click - Offset (3rd icon from the bottom)
• In the Offset selection popup, Click in the white area under Figures to offset: and click the new

reference line.
• Reference Line<1> is displayed now in Figures to offset,
• Set the Distance: to be .6250 ", Click Tab, Leave Gap Type at Natural, and Click OK.



Page 22 of 27

From the Sketching toolbar, Click - Circular Arc, Center, Start, End (7th Icon down, default)
• Click the end of the newly offset line that is on the Y-Axis,
• Drag to the right 2 grid squares (.2500") and click on the grid to start the arc,
• Drag up and over the center and down to the other side for a 180-degree arc, Click to complete it.

From the Sketching toolbar, Click Line (The 5th Icon down)
If Required, Click Line Options (Below Reference Line Icon) -> Select Line

• Click the beginning point of the arc and drag down for a line length of .6250 ", Double Click,
• Click the ending point of the arc and drag down for a line length of .6250 ", Double Click,
• Click the Bottom end of this line, and drag to the right and Double Click on the Bottom end of the

previous Line.

  
From the Sketching toolbar, Click - Select (2nd Icon)
• Click the Line that intersects with the arc's Radius and goes out to the right to select it,
• Press Delete, to remove it.

Next, you will check the sketch with Analyse.
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From the Sketch Menu > Select Analyse
• The Analyse Sketch dialog has a number of selections to check - marked with boxes beside them -

for this exercise - they all should be checked,
• Click the Analyse Button - Ideally you should see a message below this button that is now displayed

stating "No Potential problems detected in the sketch for the current check levels…"
• If not - (IE: Disjoint Ends), Click the error, and it will be displayed in the sketch, and if it can be

Healed automatically, the Heal button will no longer be Greyed out. Click it to fix the error.
(That is why you want them all checked in the boxes!) (Email me if you get stuck on this one)

• Click Close.

While still in Sketch Mode, Select Extrude Cut from the Feature Icons, or
Cut, Extrude from the Feature Menu.

mailto:alibre_rob@hotmail.com?subject=Analyse Issue  Handle-Hole_Foot-Scrubber-1
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• From the Extrude Cut dialog, Sketch<4> is pre-selected,
• Change Type: to To Next, Leave Direction as Along Normal, Draft Angle at 0 degrees,
• Select Reverse if required, under Depth,
• Label: is Extrusion<5>, which is fine. Click OK to complete the Cut.

Great! You have cut the Hole - now lets clean it up and smooth the edges!

Left + Right Mouse Click and drag to Rotate the handle around to see the flat bottom inside of the
cut we just made. Select Zoom to window and do a close-up view of this area.

While in feature mode (not in sketch) - Shift-Click the lines at the ends of the Flat at the bottom of
the cut, then select Fillet. (Slightly move/rotate the handle to see both ends of the flat, so as to click
both lines)

• In the Fillet Edges dialog, Leave Fillet Type set to Constant Radius, and Tangent Propagate
Checked,

• In the Entities to Fillet, should be showing Edge<2> and Edge<10>,
• Set the Radius: to .0200 " - Click Tab,
• The Label: is Fillet<6>, which is fine, Click OK to Complete the Base Fillet Radius.
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• Now Click the two Flat surfaces upper and lower (Rotate the part around to get both sides selected,
remember to shift-click the second side)

• Again, Select Feature Fillet.

• In the Fillet Edges dialog, Leave Fillet Type set to Constant Radius, and Tangent Propagate
Checked,

• In the Entities to Fillet, should be showing Face<5> and Face<3>,
• Leave the Radius: set at .0200 ", and Label: defaulted at Fillet<7>. Click OK to complete.

Super! Much Nicer! Now let's give it some Color, and re-save it!



Page 26 of 27

First - Click in the Workspace in an open area to deselect the part and any features.
From the Edit Menu - Select Color Properties, or
Right-Click in the part workspace, and Select Color Properties from the menu.

• Leave Opacity at 100%, Set Reflectivity to 10% by Clicking to the right of the slider once,

• Select the Color button - and from the Basic Colors - click the First Column, 2nd Row - Red Color,
• Confirm the color values, and Click OK to accept the Color and close the Color selector,

• Then Click OK to Close the Color Properties dialog and accept the settings of Color, Reflectivity,
and Opacity.
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Finally, Click on the Save Icon (Floppy Disk) or select File, Save (Or Ctrl+S) and click Save in the
Save dialog to update our save of the file..

Congratulations!

You have completed the Sweep_Foot-Scrubber-1 Tutorial!
(Complete Version)

Give me feedback on this tutorial!
Send email

If you found this and you don't yet have a copy of Alibre Design - Click this Link for a 30-Day Free Trial Copy!

mailto:alibre_rob@hotmail.com?subject=Sweep_Foot-Scrubber-1_Complete
http://www.alibre.com/register/trial.aspx?source=CNSLT015

